Author Topic: Translation  (Read 4530 times)

Offline Hogni

  • Member
  • Posts: 5
    • View Profile
Translation
« on: October 30, 2010, 12:13:49 »
Hi, i have just started using the program and i have to say that i like it so far, so keep up the good work! now came across your translation page and thought it would be nice to have it in my language(Icelandic) i did some translations in the poedit program and then i wanted to import the language file into the language folder to see how my translations worked but it did not work, is it not possible to save the language file and open the program to see how you are doing and then continue with the translation? Hope this makes sense :)

Offline Timo

  • Administrator
  • Member
  • Posts: 304
    • View Profile
Re: Translation
« Reply #1 on: November 02, 2010, 11:15:27 »
Hello, it isn't that easy to put in the translations yourself.

But if you really want to try, this is how:
 - Compile your translation with Poedit to pigeonplanner.mo
 - Go to your Pigeon Planner installation directory and create this folder: languages\is\LC_MESSAGES\ and put the pigeonplanner.mo file in there
 - Create the folder share\locale\is\LC_MESSAGES\
 - Download the files I attached to this post into that newly created folder

So, if Pigeon Planner is installed in c:\Program Files\, make sure you have these files/folders:
 - C:\Program Files\Pigeon Planner\languages\is\LC_MESSAGES\pigeonplanner.mo
 - C:\Program Files\Pigeon Planner\share\locale\is\LC_MESSAGES\gtk20-properties.mo
 - C:\Program Files\Pigeon Planner\share\locale\is\LC_MESSAGES\gtk20.mo
 - C:\Program Files\Pigeon Planner\share\locale\is\LC_MESSAGES\glib20.mo
 - C:\Program Files\Pigeon Planner\share\locale\is\LC_MESSAGES\atk10.mo

Normally the program should now start in Icelandic.

Offline Hogni

  • Member
  • Posts: 5
    • View Profile
Re: Translation
« Reply #2 on: November 03, 2010, 01:50:24 »
Hi, thank you very much for this, however i have done as you say and it does not work, i have not finished translating(about 45% finished), would that matter? in poedit i just go to save as, and change the extension to .mo, could that matter?

I also noticed that the files you attached are not of similar size as, lets say the ones for the dutch translation, is this normal?

Offline Timo

  • Administrator
  • Member
  • Posts: 304
    • View Profile
Re: Translation
« Reply #3 on: November 03, 2010, 11:09:30 »
Ow, I see you have to turn on the option to compile to a mo.
In Poedit, go to Edit=>Preferences=>Editor, and turn on the top option "Automaticly compile .mo file on save".
If you save your translation, you will have a po and mo file.

It won't matter if you haven't fully translated yet, the program will be half English, half Icelandic then.
It's also normal that the attached files aren't the same size. This happens because translated strings aren't the same length in every language, so you get larger/smaller filesizes.

Let me know if it works!

Offline Hogni

  • Member
  • Posts: 5
    • View Profile
Re: Translation
« Reply #4 on: November 03, 2010, 22:13:56 »
no, still no luck, are there no other files that need modification? Should the option for Icelandic show up in the preferences menu in the language drop down list?

Offline Timo

  • Administrator
  • Member
  • Posts: 304
    • View Profile
Re: Translation
« Reply #5 on: November 04, 2010, 11:16:45 »
Hmm that's weird. Can you look into the logfile (File=>Logfile viewer) and post the last line. It should be something like this:
[2010-11-04 11:13:36,944] PigeonPlanner DEBUG: Locale: nl_BE

It is normal that the language doesn't show up in the preferences, it is something I need to code. But make sure the language is set to "Default", then it will take your system settings.

Offline Hogni

  • Member
  • Posts: 5
    • View Profile
Re: Translation
« Reply #6 on: November 04, 2010, 20:12:15 »
here is what is in the logfile viewer


[2010-11-04 19:08:50,530] PigeonPlanner INFO: Version: 0.8.2
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: Home path: C:\Documents and Settings\Högni
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: Prefs path: C:\Documents and Settings\Högni\Application Data\pigeonplanner
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: Current path: C:\Program Files\Pigeon Planner
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: Windows version: 5, 1, 2600, 2, Service Pack 3
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: Python version: 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: GTK+ version: 2.18.7
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: PyGTK version: 2.16.0
[2010-11-04 19:08:50,530] PigeonPlanner DEBUG: Locale: en
[2010-11-04 19:08:51,171] pigeonplanner.mainwindow INFO: Start: Auto check for updates
[2010-11-04 19:08:51,530] pigeonplanner.mainwindow INFO: End: Already running the latest version

Offline Timo

  • Administrator
  • Member
  • Posts: 304
    • View Profile
Re: Translation
« Reply #7 on: November 06, 2010, 14:25:24 »
Apparently you system is in English, not Icelandic. So it will use the English translations.

What you can do is replace another language, let's say Dutch. So replace the following files with the Icelandic ones:
 - C:\Program Files\Pigeon Planner\languages\nl\LC_MESSAGES\pigeonplanner.mo
 - C:\Program Files\Pigeon Planner\share\locale\nl\LC_MESSAGES\gtk20-properties.mo
 - C:\Program Files\Pigeon Planner\share\locale\nl\LC_MESSAGES\gtk20.mo
 - C:\Program Files\Pigeon Planner\share\locale\nl\LC_MESSAGES\glib20.mo
 - C:\Program Files\Pigeon Planner\share\locale\nl\LC_MESSAGES\atk10.mo

Then go to the preferences dialog and select Dutch as the lanaguage.

Offline Hogni

  • Member
  • Posts: 5
    • View Profile
Re: Translation
« Reply #8 on: November 07, 2010, 14:31:41 »
Thank you very much Timo, this works perfectly now, it really helps to see the translation inside the program to make the translation better.

 

nominee