Pigeon Planner forum

Testing 1.9

Timo · 6 · 4933

Offline Timo

  • Administrator
  • Member
    • Posts: 355
    • View Profile
I just uploaded version 1.9.0 which will eventually become 2.0.

What has changed since 1.8.0?
 * Always add and edit pigeons in a seperate dialog
 * Added a location chooser
 * Keep filter active after closing it
 * Fixed reporterror on missing image
 * Fixed rare error in filechoosers
 * Fixed missing translation strings
 * Lowered required GTK version
 * Hold widgets in seperate class
 * Changed application imports
 * Greatly improved buildscripts
 * Many more code changes and cleanups

These are mostly code changes, more features will be added later.
Visible user changes:
 * Adding and editing a pigeon is now always done in a seperate dialog instead of the in-place window edit.
 * A new location chooser which will detect the latitude and longitude values automaticly for a given location. This can either be a city, street or full address.
 * The filter now keeps active after you close its window.

Mac OS X: From this version on, there will be a Mac package available. This is an experimental package for OS X 10.5 or higher and Intel only. I don't own a Mac myself, so reports are welcome.

Translations can be done trough: https://translations.launchpad.net/pigeonplanner
The files can be found here: https://sourceforge.net/projects/pigeonplanner/files/Unstable/

Again, no database changes are made, so this release is compatible with the 1.8 and 1.6 series.


Offline Timo

  • Administrator
  • Member
    • Posts: 355
    • View Profile
Little change of plans: this is released as 1.10.0. Downloads and changelog can be found at the download page: http://www.pigeonplanner.com/download

Note: a Mac build will follow, there are some issues at the moment.


Offline DonViseroo

  • Member
    • Posts: 6
    • View Profile
Ik heb de versie op mijn twee computers gedownload, maar elke keer ik mijn pigeonplanner open, komt op beide computers een schermpje met 'update beschikbaar! er is een update beschikbaar, wilt u deze nu downloaden', de versie die ik nu heb is 1.10.0. heb het al eens opnieuw gedownload, maar het blijft er op komen.


Offline Timo

  • Administrator
  • Member
    • Posts: 355
    • View Profile
Klopt, deze fout zit er blijkbaar al jaren in, maar komt nu pas tevoorschijn omwille van het specifieke versienummer. Een nieuwe versie staat binnen een paar uurtjes online!



Offline Timo

  • Administrator
  • Member
    • Posts: 355
    • View Profile
Het staat online.

English:
Due to an error in the updatechecker, the program will incorrectly report that a new version is available, even if the latest is installed. This is now fixed in version 1.10.1
Complete changes:
 * Fixed version comparison in updater
 * Fixed unhandled error when connection fails in location chooser
 * Include parser version on parsing error
 * Disable Geopy logmessages lower than ERROR